Problemas con los rpm en OpenSuSE

Mientras esperamos la llegada de KDE 4.5 os pongo la solución a un problema que me encontré a la vuelta de mis vacaciones con mi portátil: no podía actualizar ni instalar nada.
Al parecer la útima actualización no la realicé correctamente y me aparecía un mensaje de error parecido a este:

Subprocess failed. Error: RPM fallido: error: db3 error(-30987) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found
error: error(-30987) getting «/sbin/ldconfig» records from Requirename index
error: db3 error(-30987) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found
error: error(-30987) getting «» records from Requireversion index
error: db3 error(-30987) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found
error: error(-30987) getting «» records from Requireversion index
error: db3 error(-30987) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found
error: error(-30987) getting «» records from Requireversion index
error: db3 error(-30987) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found
error: error(-30987) getting «» records from Requireversion index
error: db3 error(-30987) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found
error: error(-30987) getting «» records from Requireversion index
error: db3 error(-30987) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found
error: error(-30987) getting «» records from Requireversion index

La solución la encontré en Foro SuSE, y no podía ser más sencilla, debía escribir en una consola (pulsando enter al finalizar cada línea y teniendo precaución porque en el primer comando, delante de rebuilddb hay dos guiones, no uno largo [- -, pero juntos])(cosas del WordPress)

sudo rpm –rebuilddb
zypper ref
zypper ve
zypper up

Con ello reconstruía la base de datos y actualizaba los repositorios y programas.

Vía: Foro SuSE

5 comentarios en “Problemas con los rpm en OpenSuSE”

  1. Desde anoche está disponible KDE 4.5 Final en el repositorio KDE/Distro:/Factory de OpenSuSE. Por ahora va muy fino, aunque los programas de KDEPIM (KMail, Akregator, Kontact,…) me salen en inglés sin posibilidad, por ahora, de cambiarlos. ¿A alguien más le pasa esto?

    Un saludo y enhorabuena por el blog!

  2. Pingback: Bitacoras.com

  3. Pingback: BlogESfera.com

  4. Hola, yo tambien he tenido ese fallo cuando actualize opensuse de 11.2 a 11.3, lo corregi segun tu lo indicas, pero ahora tengo el problema que se congela kde, lo instale de nuevo (desde cero) y aun persiste el problema, antes no me sucedia con la 11.2, creo que es un fallo de esta nueva version espero que pronto encuentren la solucion, mi equipo una latop emachines 750 pentium core duo, DD=160 Gb y ram=2Gb saludos

Deja un comentario

Tu dirección de correo electrónico no será publicada.